Mikrotik 2 ISP memisahkan beberapa komputer beda ISP

Ada kalanya kita ingin memisahkan beberapa komputer menjadi 2 kelompok dengan ISP yang berbeda di dalam 1 Router Mikrotik. Alasannya mungkin 1 ISP tidak cukup bandwithnya untuk semua komputer sehingga perlu 2 ISP. Atau mungkin ISP pertama untuk browsing sedangkan ISP kedua dengan kualitas yang lebih baik untuk Game.

.

 

Dalam keadaan darurat mungkin kita terpaksa perlu menggunakan Modem 4G untuk warnet atau kantor, karena koneksi utama sedang bermasalah. Biasanya koneksi internet dengan 1 buah modem 4G tidak cukup untuk membackup semua PC warnet, maka perlu beberapa modem.

 

Rancangan topologi network dapat dilihat pada gambar di atas,  secara lengkapnya akan dibahas satu-persatu bagaimana mengkonfigurasikan mikrotik load balancing 2 isp sesuai dengan keadaan seperti gambar tersebut.

Sebut saja interface yang digunakan pada mikrotik router adalah ether1 , ether2, dan ether3 dengan kondisi sebagai berikut :

ether1 (ISP1) : 111.111.111.111
ehter2 (ISP2) : 222.222.222.222
ehter3 (LAN)  : 192.168.254.1

Tambahkan IP Address pada mikrotik box untuk keperluan diatas:
/ip address
add address=111.111.111.111/24 network=111.111.111.0 broadcast=111.111.111.255 interface=ether1 
add address=222.222.222.222/24 network=222.222.222.0 broadcast=222.222.222.255 interface=ether2
add address=192.168.254.1/24 network=192.168.254.0 broadcast=192.168.254.255 interface=ether3

4 buah workstation dengan ip : 192.168.254.2 (WORKST-1),
192.168.254.3(WORKST-2), 192.168.254.4(WORKST-3) dan 192.168.254.5(WORKST-3)

Disini akses internet akan dipecah menjadi dua jalur,  WORKST-1 dan 2 melalui ISP1, sedangkan WORKST-3 dan 4 melalui ISP2, namun jika salah satu ISP putus atau down, semua akses dari semua WORKST akan dialihkan ke jalur yang hidup, hal ini dapat diatur menggunakan mikrotik load balancing.

Berikut langkah yang dilakukan untuk mengkonfigurasi keperluan diatas:

1. Buat Adress List pada IP Firewall :

/ip firewall address-list
add list=jalur1 address="192.168.254.2"
add list=jalur1 address="192.168.254.3"
add list=jalur2 address="192.168.254.4"
add list=jalur2 address="192.168.254.5"

 

2. Konfigurasi NAT dan MANGLE

 

/ip firewall nat
add chain=srcnat action=masquerade to-addresses=111.111.111.111 src-address-list=jalur1 comment="via ISP1" 
add chain=srcnat action=masquerade to-addresses=222.222.222.222 src-address-list=jalur2 comment="via ISP2"

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=jalur1-route passthrough=no\
src-address-list=jalur1 in-interface=ether3 comment"Mark Routing Jalur1"
add chain=prerouting action=mark-routing new-routing-mark=jalur2-route passthrough=no\
src-address-list=jalur2 in-interface=ether3 comment"Mark Routing Jalur2"

 

3. IP Routes dan Rule

/ip route
add dst-address=0.0.0.0/0 gateway=111.111.111.1 check-gateway=ping distance=1 scope=30\
target-scope=10 routing-mark=jalur1-route
add dst-address=0.0.0.0/0 gateway=222.222.222.1 check-gateway=ping distance=1 scope=30\
target-scope=10 routing-mark=jalur1-route
add dst-address=0.0.0.0/0 gateway=111.111.111.1 check-gateway=ping distance=1 scope=30\
target-scope=10 routing-mark=jalur2-route
add dst-address=0.0.0.0/0 gateway=222.222.222.1 check-gateway=ping distance=1 scope=30\
target-scope=10 routing-mark=jalur2-route
add dst-address=0.0.0.0/0 gateway=111.111.111.1 check-gateway=ping distance=1 scope=30\
target-scope=10 
add dst-address=0.0.0.0/0 gateway=222.222.222.1 check-gateway=ping distance=1 scope=30\
target-scope=10 

/ip route rule
add dst-address=111.111.111.0/24 action=lookup table=main
add dst-address=222.222.222.0/24 action=lookup table=main
add dst-address=192.168.254.0/24 action=lookup table=main
add src-address=111.111.111.0/24 action=lookup table=jalur1-route
add src-address=222.222.222.0/24 action=lookup table=jalur2-route
add routing-mark=jalur1-route action=lookup table=jalur1-route
add routing-mark=jalur2-route action=lookup table=jalur2-route

Konfigurasi IP route rule diatas juga berguna untuk melakukan remote login dari internet, dengan syntax diatas router menjadi visible dari dua arah ISP yang berbeda, hasil akhir konfigurasi pada IP Route jika dilihat melalui winbox akan terlihat seperti gambar dibawah:

Terlihat pada gambar tersebut routing yang di mark dengan warna biru dan hitam, artinya hitam menandakan bahwa routing tersebut aktif untuk masing-masing jalur, dan warna biru merupakan routing sebagai backup jika routing yang sedang aktif mengalami kendala atau terputus, maka secara otomatis routing akan berpindah.

Untuk memastikan jalur sudah berjalan dengan benar, sobat bisa mencobanya dengan melakukan traceroute untuk setiap IP source ke arah situs tertentu, jika dirasakan jalur yang dilalui sudah benar, maka mikrotik load balancing 2 ISP dengan LAN IP address list sudah berhasil dilakukan, tinggal dilakukan pengembangan yang diperlukan sesuai dengan keinginan seorang admin jaringan.

Pada artikel ini menggunakan 2 ISP, namun jika perlu bisa juga dengan 3 atau 4 ISP, setingannya sama tinggal menambahkan saja.

One thought on “Mikrotik 2 ISP memisahkan beberapa komputer beda ISP

  1. Antara klient jalur1&jalur2 bisa saling ping ya Mas…

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *